Vaisala Xweather Lightning Network - Reduced Data Rates

Incident Report for Vaisala Xweather

Resolved

We have failed over and data looks stable.
Posted Jul 02, 2026 - 03:15 CDT

Monitoring

Data is flowing much better, we are applying the last few optimizations
Posted Jul 02, 2026 - 03:06 CDT

Identified

We have failed over to our other data center to get a more stable connection and are ensuring data is flowing properly
Posted Jul 02, 2026 - 02:53 CDT

Monitoring

We have made some changes to help mitigate the issue
Posted Jul 02, 2026 - 02:37 CDT

Identified

We have identified the issue and are moving to mitigate the latency spikes
Posted Jul 02, 2026 - 02:32 CDT

Investigating

We are investigating some issues with the data rates from our lightning network. This may contribute to missing lightning events.
Posted Jul 02, 2026 - 02:08 CDT
This incident affected: Weather Data API (Lightning Endpoints), Raster Maps (Lightning), and Vaisala Xweather Lightning Data.