Vaisala Xweather Data API Increased Error Rates

Incident Report for Vaisala Xweather

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 14:11 CST

Monitoring

We have applied the permanent fix and are back to full strength in our cluster. We'll continue to keep a close eye on things.
Posted Mar 05, 2026 - 14:05 CST

Identified

We've identified the core issue, a mitigation is already in place and we're monitoring recovery.
Posted Mar 05, 2026 - 14:01 CST

Investigating

We are currently investigating higher than normal error rates and latencies with the Vaisala Xweather Data API.
Posted Mar 05, 2026 - 13:56 CST
This incident affected: Weather Data API (Conditions Endpoint, Forecasts Endpoint, API - General).