Vaisala Xweather Maps Increased Error Rates and Latencies

Incident Report for Vaisala Xweather

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:10 CDT

Update

Latencies and error rates have returned to normal levels. We will continue to monitor the situation.
Posted Oct 20, 2025 - 16:03 CDT

Monitoring

Improvements are now occurring for the Raster Maps and MapsGL services as our cloud provider continues recovery. We are monitoring performance to ensure full stability.
Posted Oct 20, 2025 - 15:00 CDT

Identified

We have identified the cause of increased latencies and intermittent errors affecting our Raster Maps and MapsGL services. The issue is tied to an ongoing incident with our cloud provider.

Our team continues to monitor the situation closely.
Posted Oct 20, 2025 - 14:39 CDT
This incident affected: Raster Maps (Maps - General) and Xweather MapsGL.