Service update delays

Incident Report for Vaisala Xweather

Resolved

All observation data and webhook services have fully recovered, and systems are operating normally.
Posted Oct 20, 2025 - 07:24 CDT

Update

Observation data has fully updated. Webhook deliveries are recovering and continuing to work through their backlog. We will continue to monitor system performance and provide updates as recovery completes.
Posted Oct 20, 2025 - 07:14 CDT

Monitoring

Our cloud provider, AWS, experienced a significant outage overnight. The core issue has been resolved, but some observation updates and webhook deliveries may continue to experience temporary delays as systems recover. We are monitoring performance closely and will provide updates as the backlog clears.
Posted Oct 20, 2025 - 06:18 CDT
This incident affected: Weather Data API (API - General) and Webhooks.